<!DOCTYPE html>
<html class="no-js mh-one-sb" lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article#">
<head itemscope itemtype="https://schema.org/WebPage">
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="http://gmpg.org/xfn/11" />
<title>Random Musing: Our worst can&#8217;t bring out our best. &#8211; Critique Echo Newspaper</title>
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Critique Echo Newspaper &raquo; Feed" href="http://www.critiqueecho.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Critique Echo Newspaper &raquo; Comments Feed" href="http://www.critiqueecho.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Critique Echo Newspaper &raquo; Random Musing: Our worst can&#8217;t bring out our best. Comments Feed" href="http://www.critiqueecho.com/random-musing-our-worst-cant-bring-out-our-best/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.critiqueecho.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.0.4"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css'  href='http://www.critiqueecho.com/wp-includes/css/dist/block-library/style.min.css?ver=5.0.4' type='text/css' media='all' />
<link rel='stylesheet' id='Total_Soft_Poll-css'  href='http://www.critiqueecho.com/wp-content/plugins/Poll/CSS/Total-Soft-Poll-Widget.css?ver=5.0.4' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css-css'  href='http://www.critiqueecho.com/wp-content/plugins/Poll/CSS/totalsoft.css?ver=5.0.4' type='text/css' media='all' />
<link rel='stylesheet' id='wabtn-style-css'  href='http://www.critiqueecho.com/wp-content/plugins/whatsapp/style.css?ver=5.0.4' type='text/css' media='all' />
<link rel='stylesheet' id='mh-magazine-css'  href='http://www.critiqueecho.com/wp-content/themes/mh-magazine/style.css?ver=3.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='mh-font-awesome-css'  href='http://www.critiqueecho.com/wp-content/themes/mh-magazine/includes/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans:300,400,400italic,600,700' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css'  href='http://www.critiqueecho.com/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<script type='text/javascript' src='http://www.critiqueecho.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.critiqueecho.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://www.critiqueecho.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var object = {"ajaxurl":"http:\/\/www.critiqueecho.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.critiqueecho.com/wp-content/plugins/Poll/JS/Total-Soft-Poll-Widget.js?ver=5.0.4'></script>
<script type='text/javascript' src='http://www.critiqueecho.com/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1'></script>
<script type='text/javascript' src='http://www.critiqueecho.com/wp-content/themes/mh-magazine/js/scripts.js?ver=3.6.1'></script>
<link rel='https://api.w.org/' href='http://www.critiqueecho.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.critiqueecho.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.critiqueecho.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Random Musing: Let He That Thinks He stands Take Heed.' href='http://www.critiqueecho.com/random-musing-let-he-that-thinks-he-stands-take-heed/' />
<meta name="generator" content="WordPress 5.0.4" />
<link rel="canonical" href="http://www.critiqueecho.com/random-musing-our-worst-cant-bring-out-our-best/" />
<link rel="alternate" type="application/json+oembed" href="http://www.critiqueecho.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.critiqueecho.com%2Frandom-musing-our-worst-cant-bring-out-our-best%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.critiqueecho.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.critiqueecho.com%2Frandom-musing-our-worst-cant-bring-out-our-best%2F&#038;format=xml" />

<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>
<!-- Graceful Pull-Quotes plugin v2.6.1 -->
	<link rel="stylesheet" href="http://www.critiqueecho.com/wp-content/plugins/graceful-pull-quotes/resources/jspullquotes-core.css" type="text/css" />
	<link rel="stylesheet" href="http://www.critiqueecho.com/wp-content/plugins/graceful-pull-quotes/styles/Modern.css" type="text/css" />
	<script type="text/javascript">
		var jspq_options = new Array("1", "1", "right", "1", "1", "blockquote", "pullquote", "pullquote pqRight");
	</script>
	<script type="text/javascript" src="http://www.critiqueecho.com/wp-content/plugins/graceful-pull-quotes/resources/jspullquotes.js"></script>
<!-- end pull-quote additions -->
<style type="text/css">
.mh-header { background: #fcfcfc; }
.mh-navigation li:hover, .mh-navigation ul li:hover > ul, .mh-main-nav-wrap, .mh-main-nav, .mh-social-nav li a:hover, .entry-tags li, .mh-slider-caption, .mh-widget-layout8 .mh-widget-title .mh-footer-widget-title-inner, .mh-widget-col-1 .mh-slider-caption, .mh-widget-col-1 .mh-posts-lineup-caption, .mh-carousel-layout1, .mh-spotlight-widget, .mh-social-widget li a, .mh-author-bio-widget, .mh-footer-widget .mh-tab-comment-excerpt, .mh-nip-item:hover .mh-nip-overlay, .mh-widget .tagcloud a, .mh-footer-widget .tagcloud a, .mh-footer, .mh-copyright-wrap, input[type=submit]:hover, #infinite-handle span:hover { background: #298741; }
.mh-extra-nav-bg { background: rgba(41, 135, 65, 0.2); }
.mh-slider-caption, .mh-posts-stacked-title, .mh-posts-lineup-caption { background: #298741; background: rgba(41, 135, 65, 0.8); }
@media screen and (max-width: 900px) { #mh-mobile .mh-slider-caption, #mh-mobile .mh-posts-lineup-caption { background: rgba(41, 135, 65, 1); } }
.slicknav_menu, .slicknav_nav ul, #mh-mobile .mh-footer-widget .mh-posts-stacked-overlay { border-color: #298741; }
.mh-copyright, .mh-copyright a { color: #fff; }
.mh-widget-layout4 .mh-widget-title { background: #2579e8; background: rgba(37, 121, 232, 0.6); }
.mh-preheader, .mh-wide-layout .mh-subheader, .mh-ticker-title, .mh-main-nav li:hover, .mh-footer-nav, .slicknav_menu, .slicknav_btn, .slicknav_nav .slicknav_item:hover, .slicknav_nav a:hover, .mh-back-to-top, .mh-subheading, .entry-tags .fa, .entry-tags li:hover, .mh-widget-layout2 .mh-widget-title, .mh-widget-layout4 .mh-widget-title-inner, .mh-widget-layout4 .mh-footer-widget-title, .mh-widget-layout5 .mh-widget-title-inner, .mh-widget-layout6 .mh-widget-title, #mh-mobile .flex-control-paging li a.flex-active, .mh-image-caption, .mh-carousel-layout1 .mh-carousel-caption, .mh-tab-button.active, .mh-tab-button.active:hover, .mh-footer-widget .mh-tab-button.active, .mh-social-widget li:hover a, .mh-footer-widget .mh-social-widget li a, .mh-footer-widget .mh-author-bio-widget, .tagcloud a:hover, .mh-widget .tagcloud a:hover, .mh-footer-widget .tagcloud a:hover, .mh-posts-stacked-meta, .page-numbers:hover, .mh-loop-pagination .current, .mh-comments-pagination .current, .pagelink, a:hover .pagelink, input[type=submit], #infinite-handle span { background: #2579e8; }
.mh-main-nav-wrap .slicknav_nav ul, blockquote, .mh-widget-layout1 .mh-widget-title, .mh-widget-layout3 .mh-widget-title, .mh-widget-layout5 .mh-widget-title, .mh-widget-layout8 .mh-widget-title:after, #mh-mobile .mh-slider-caption, .mh-carousel-layout1, .mh-spotlight-widget, .mh-author-bio-widget, .mh-author-bio-title, .mh-author-bio-image-frame, .mh-video-widget, .mh-tab-buttons, .bypostauthor .mh-comment-meta, textarea:hover, input[type=text]:hover, input[type=email]:hover, input[type=tel]:hover, input[type=url]:hover { border-color: #2579e8; }
.mh-dropcap, .mh-carousel-layout1 .flex-direction-nav a, .mh-carousel-layout2 .mh-carousel-caption, .mh-posts-digest-small-category, .mh-posts-lineup-more, .bypostauthor .mh-comment-meta-author:after, .mh-comment-meta-links .comment-reply-link:before, #respond #cancel-comment-reply-link:before { color: #2579e8; }
.entry-content a, .mh-comment-content a { color: #0aaa01; }
a:hover, .entry-content a:hover, .mh-comment-content a:hover, #respond a:hover, .mh-meta a:hover, .mh-breadcrumb a:hover, .mh-tabbed-widget a:hover { color: #0707f2; }
</style>
<!--[if lt IE 9]>
<script src="http://www.critiqueecho.com/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script>
<![endif]-->


<!-- wpsso meta tags begin -->
<meta name="wpsso:mark:begin" content="wpsso meta tags begin"/>
<!-- generator:1 --><meta name="generator" content="WPSSO Core 4.23.0/L"/>
<!-- generator:2 --><meta name="generator" content="WPSSO SSB 2.11.0/L"/>
<!-- generator:3 --><meta name="generator" content="WPSSO UM 1.18.0/F"/>
<link rel="shortlink" href="http://www.critiqueecho.com/?p=9692"/>
<!-- fb:admins:1 --><meta property="fb:admins" content="critiqueechonews"/>
<!-- fb:admins:2 --><meta property="fb:admins" content="othman.sheriff"/>
<meta property="fb:app_id" content="234540849953303"/>
<meta property="og:type" content="article"/>
<meta property="og:url" content="http://www.critiqueecho.com/random-musing-our-worst-cant-bring-out-our-best/"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:site_name" content="Critiqueecho.com"/>
<meta property="og:title" content="Random Musing: Our worst can&rsquo;t bring out our best."/>
<meta property="og:description" content="There is a usual angst when it comes to writing about public figures, especially when these figures are politicians who are caught in the eye of the storm. But it is funny that the dogs are out so soon to give life to the eerie omens of the immediate past. As people continue to gawp at what is..."/>
<meta property="og:updated_time" content="2019-05-07T11:21:13+00:00"/>
<!-- og:image:1 --><meta property="og:image" content="http://www.critiqueecho.com/wp-content/uploads/2015/09/bibleimage-300x315.jpg"/>
<!-- og:image:1 --><meta property="og:image:width" content="300"/>
<!-- og:image:1 --><meta property="og:image:height" content="315"/>
<meta property="article:publisher" content="https://www.facebook.com/critiqueechonews"/>
<meta property="article:published_time" content="2019-05-07T11:20:46+00:00"/>
<meta property="article:modified_time" content="2019-05-07T11:21:13+00:00"/>
<meta property="article:section" content="Politics"/>
<meta name="weibo:article:create_at" content="2019-05-07 11:20:46"/>
<meta name="weibo:article:update_at" content="2019-05-07 11:21:13"/>
<meta name="twitter:domain" content="www.critiqueecho.com"/>
<meta name="twitter:site" content="@critiqueecho"/>
<meta name="twitter:title" content="Random Musing: Our worst can&rsquo;t bring out our best."/>
<meta name="twitter:description" content="There is a usual angst when it comes to writing about public figures, especially when these figures are politicians who are caught in the eye of the storm. But it is funny that the dogs are out so..."/>
<meta name="twitter:card" content="summary_large_image"/>
<meta name="twitter:image" content="http://www.critiqueecho.com/wp-content/uploads/2015/09/bibleimage-300x200.jpg"/>
<link itemprop="url" href="http://www.critiqueecho.com/random-musing-our-worst-cant-bring-out-our-best/"/>
<meta itemprop="name" content="Random Musing: Our worst can&rsquo;t bring out our best."/>
<meta itemprop="description" content="There is a usual angst when it comes to writing about public figures, especially when these figures are politicians who are caught in the eye of the storm. But it is funny that the dogs are out so soon to give life to the eerie omens of the..."/>
<meta itemprop="datePublished" content="2019-05-07T11:20:46+00:00"/>
<meta itemprop="dateModified" content="2019-05-07T11:21:13+00:00"/>
<meta name="author" content="CEN"/>
<meta name="thumbnail" content="http://www.critiqueecho.com/wp-content/uploads/2015/09/bibleimage-150x150.jpg"/>
<meta name="robots" content="index, follow"/>
<noscript itemprop="author" itemscope itemtype="https://schema.org/Person">
	<link itemprop="url" href="http://www.critiqueecho.com"/>
	<meta itemprop="name" content="CEN"/>
	<meta itemprop="description" content="Critique Echo Newspaper is a major source of news and objective analyses about governance, democracy and human-right. Edited and published in Kenema city, eastern Sierra Leone, the outlet is generally referred to as a level plying ground for the youths, women and children."/>
</noscript>
<noscript itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
	<link itemprop="url" href="http://www.critiqueecho.com/wp-content/uploads/2015/09/bibleimage-800x533.jpg"/>
	<meta itemprop="width" content="800"/>
	<meta itemprop="height" content="533"/>
</noscript>
<meta name="wpsso:mark:end" content="wpsso meta tags end"/>
<!-- wpsso meta tags end -->
<!-- added on 2019-05-09T06:54:59+00:00 in 0.001096 secs from http://www.critiqueecho.com -->

<script type="text/javascript" id="wpssossb-header-script">
	window.___gcfg = { lang: "en-US" };
	function wpsso_insert_js( script_id, url, async ) {
		if ( document.getElementById( script_id + "-js" ) ) return;
		var async = typeof async !== "undefined" ? async : true;
		var script_pos = document.getElementById( script_id );
		var js = document.createElement( "script" );
		js.id = script_id + "-js";
		js.async = async;
		js.type = "text/javascript";
		js.language = "JavaScript";
		js.src = url;
		script_pos.parentNode.insertBefore( js, script_pos );
	};
</script>
<!-- wpssossb header javascript begin -->
<!-- generated on 2019-05-09T06:54:59+00:00 -->
<!-- wpssossb header: facebook script location is footer -->
<!-- wpssossb header javascript end -->
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #2579e8; }
</style>
</head>
<body id="mh-mobile" class="post-template-default single single-post postid-9692 single-format-standard custom-background mh-wide-layout mh-right-sb mh-loop-layout4 mh-widget-layout6 mh-header-transparent" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<div class="mh-header-nav-mobile clearfix"></div>
	<div class="mh-preheader">
    	<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-top-left mh-col-2-3 clearfix">
											<nav class="mh-navigation mh-header-nav mh-header-nav-top clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
							<div class="menu-about-us-container"><ul id="menu-about-us" class="menu"><li id="menu-item-226" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-226"><a href="http://www.critiqueecho.com/diaspora-corner/">Contact Us</a></li>
<li id="menu-item-227" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-227"><a href="http://www.critiqueecho.com/african-news/">Who We Are</a></li>
<li id="menu-item-228" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-228"><a href="http://www.critiqueecho.com/sample-page-2/">Meet Our Team</a></li>
<li id="menu-item-6945" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6945"><a href="http://www.critiqueecho.com/your-article/">Your Article</a></li>
<li id="menu-item-6946" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6946"><a href="http://www.critiqueecho.com/diaspora-corner/">Contact Us</a></li>
<li id="menu-item-8327" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-8327"><a href="http://www.critiqueecho.com/">Home</a></li>
</ul></div>						</nav>
									</div>
										<div class="mh-header-bar-content mh-header-bar-top-right mh-col-1-3 clearfix">
											<div class="mh-header-date mh-header-date-top">
							09/05/2019						</div>
									</div>
					</div>
	</div>
<header class="mh-header" itemscope="itemscope" itemtype="http://schema.org/WPHeader">
	<div class="mh-container mh-container-inner clearfix">
		<div class="mh-custom-header clearfix">
<a class="mh-header-image-link" href="http://www.critiqueecho.com/" title="Critique Echo Newspaper" rel="home">
<img class="mh-header-image" src="http://www.critiqueecho.com/wp-content/uploads/2017/02/cropped-CEN-Logo.jpg" height="150" width="1440" alt="Critique Echo Newspaper" />
</a>
</div>
	</div>
	<div class="mh-main-nav-wrap">
		<nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
			<div class="menu-cen-container"><ul id="menu-cen" class="menu"><li id="menu-item-8385" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-8385"><a href="http://www.critiqueecho.com/">Home</a></li>
<li id="menu-item-6948" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-6948"><a href="http://www.critiqueecho.com/category/critique-column/">Critique</a></li>
<li id="menu-item-6952" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6952"><a href="http://www.critiqueecho.com/category/diasporal-exclusive/">Diasporal Exclusive</a></li>
<li id="menu-item-6954" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6954"><a href="http://www.critiqueecho.com/category/world-news/">World News</a>
<ul class="sub-menu">
	<li id="menu-item-6955" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6955"><a href="http://www.critiqueecho.com/category/world-news/african-news/">Africa</a></li>
	<li id="menu-item-6956" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6956"><a href="http://www.critiqueecho.com/category/world-news/middle-east/">Middle East/Asia</a></li>
	<li id="menu-item-7253" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7253"><a href="http://www.critiqueecho.com/category/world-news/african-news/">Africa</a></li>
	<li id="menu-item-7254" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7254"><a href="http://www.critiqueecho.com/category/world-news/american-news/">America</a></li>
	<li id="menu-item-7255" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7255"><a href="http://www.critiqueecho.com/category/world-news/european-news/">Europe</a></li>
</ul>
</li>
<li id="menu-item-7181" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7181"><a href="http://www.critiqueecho.com/category/randommusing/">Random Musing</a></li>
<li id="menu-item-7182" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7182"><a href="http://www.critiqueecho.com/category/poems/">Poems</a></li>
<li id="menu-item-8481" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-8481"><a href="#">Useful links</a>
<ul class="sub-menu">
	<li id="menu-item-8485" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8485"><a href="http://www.sierra-leone.org/">Sierra Leone Web</a></li>
	<li id="menu-item-8483" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8483"><a href="#">Tourist info</a></li>
	<li id="menu-item-8484" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8484"><a href="#">Local news</a></li>
</ul>
</li>
<li id="menu-item-6953" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6953"><a href="http://www.critiqueecho.com/category/sport/">Sport</a></li>
</ul></div>		</nav>
	</div>
	</header>
	<div class="mh-subheader">
		<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-bottom-left mh-col-2-3 clearfix">
											<div class="mh-header-ticker mh-header-ticker-bottom">
							<div class="mh-ticker-bottom">
			<div class="mh-ticker-title mh-ticker-title-bottom">
			Latest headlines<i class="fa fa-chevron-right"></i>		</div>
		<div class="mh-ticker-content mh-ticker-content-bottom">
		<ul id="mh-ticker-loop-bottom">				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="http://www.critiqueecho.com/the-betrayal-of-trust-carries-a-heavy-taboo/" title="The Betrayal Of Trust Carries A Heavy Taboo.">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ 03/02/2019 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							The Betrayal Of Trust Carries A Heavy Taboo.						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Critique Column							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="http://www.critiqueecho.com/random-musing-our-worst-cant-bring-out-our-best/" title="Random Musing: Our worst can&#8217;t bring out our best.">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ 07/05/2019 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Random Musing: Our worst can&#8217;t bring out our best.						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Critique Column							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="http://www.critiqueecho.com/random-musing-let-he-that-thinks-he-stands-take-heed/" title="Random Musing: Let He That Thinks He stands Take Heed.">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ 23/04/2019 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Random Musing: Let He That Thinks He stands Take Heed.						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Latest Post							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="http://www.critiqueecho.com/from-ideas-to-deeds-challenges-of-our-time/" title="FROM IDEAS TO DEEDS: Challenges of Our Time">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ 23/04/2019 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							FROM IDEAS TO DEEDS: Challenges of Our Time						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Critique Column							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="http://www.critiqueecho.com/sierra-leone-minister-of-labor-social-security-ilo-100th-anniversary-statement/" title="Sierra Leone Minister of Labor &#038; Social Security ILO 100th Anniversary Statement">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ 17/04/2019 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Sierra Leone Minister of Labor &#038; Social Security ILO 100th Anniversary Statement						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Breaking News							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="http://www.critiqueecho.com/when-do-we-challenge-our-african-leaders/" title="When Do We Challenge Our African Leaders?">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ 14/04/2019 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							When Do We Challenge Our African Leaders?						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Critique Column							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="http://www.critiqueecho.com/youth-minister-receives-recognition-from-africa-armed-forces/" title="Youth Minister Receives Recognition from Africa Armed Forces">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ 11/04/2019 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Youth Minister Receives Recognition from Africa Armed Forces						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Latest Post							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="http://www.critiqueecho.com/deputy-youth-minister-lawlessness-poverty-and-corruption-are-the-real-security-threat/" title="Deputy Youth Minister:  “Lawlessness, Poverty and Corruption are the Real Security Threat”">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ 10/04/2019 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Deputy Youth Minister:  “Lawlessness, Poverty and Corruption are the Real Security Threat”						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Latest Post							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="http://www.critiqueecho.com/slrsa-deputy-executive-director-takes-road-safety-to-mile-38-police/" title="SLRSA Deputy Executive Director Takes Road Safety To Mile 38 Police">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ 24/03/2019 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							SLRSA Deputy Executive Director Takes Road Safety To Mile 38 Police						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Latest Post							</span>
											</a>
				</li>		</ul>
	</div>
</div>						</div>
									</div>
								</div>
	</div>
<div class="mh-container mh-container-outer">
<div class="mh-wrapper clearfix">
	<div class="mh-main clearfix">
		<div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><article id="post-9692" class="post-9692 post type-post status-publish format-standard has-post-thumbnail hentry category-critique-column category-cenheadlines">
	<header class="entry-header clearfix"><h1 class="entry-title">Random Musing: Our worst can&#8217;t bring out our best.</h1><p class="mh-meta entry-meta">
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="http://www.critiqueecho.com/author/cen/">CEN</a></span>
</p>
	</header>
		<div class="entry-content clearfix">
<!-- wpsso schema image for pinterest pin it button -->
<div class="wpsso-schema-image-for-pinterest" style="display:none;">
<img src="http://www.critiqueecho.com/wp-content/uploads/2015/09/bibleimage-800x533.jpg" width="0" height="0" style="width:0;height:0;" data-pin-description="There is a usual angst when it comes to writing about public figures, especially when these figures are politicians who are caught in the eye of the storm. But it is funny that the dogs are out so soon to give life to the eerie omens of the..." alt=""/>
</div><!-- .wpsso-schema-image-for-pinterest -->

<p style="text-align: justify;">There is a usual angst when it comes to writing about public figures, especially when these figures are politicians who are caught in the eye of the storm. But it is funny that the dogs are out so soon to give life to the eerie omens of the immediate past.</p>
<p style="text-align: justify;">As people continue to gawp at what is considered by some to be the logic-defying dynamism of the current administration and its comprehensible vision, I warned in my last piece that the new direction should beware of the silly season; which is the ultimate chatter of praise and the looming scenario of disenchantment; if the under- priced matter of escalating cost of living continues to limp along without change.</p>
<p style="text-align: justify;">Yes; some good things are happening and several new government initiatives are welcome. But right now radical economic stimuli are needed beyond the all-consuming songs of adoration which is exhausting the minds of everyone.</p>
<p style="text-align: justify;">So, if what I wrote in the last piece could be perceived in some quarters as criticism of the current administration, then you can understand my contention that we as a people, aside our ingrained tendency to posture in mindless partisanship, have problems accepting the truth, not to talk of letting go of our idiosyncrasies. Why are we a sentimentally hypocritic people? </p>
<p style="text-align: justify;">That the broken record I’ve been playing since the Koroma administration, regarding the mindset of our society is still the sound track of our today, says much about our disposition to a better Sierra Leone.</p>
<p style="text-align: justify;">I mean, I had to do a verbal eye-roll at some reactions to the article, in which I warned the current administration to be wary of the agama lizard syndrome and not to get carried away with its performance; especially with the increasing crescendo of what Dr Sama Banya described as “D gron dry” (the ground is dry-barren-lifeless) and which President Bio himself recently acceded to in an interview.</p>
<p style="text-align: justify;">The erudite doctor might have attributed the lamentation to members of the opposition but there is  no amount of spin that will wash the fact that devoid of the heavy inflows from corruption and unethical business practices of the immediate past, the diminishing economic pinch being felt by many of the ordinary citizens  is a threat that  will soon begin to see some of government’s efforts as a bed of nails, by the same people  whose lives have been one of trauma and which the new direction says it is trying to ameliorate.</p>
<p style="text-align: justify;">Believe me, nestled under the bridges of the populist welfare programmes of the government are thousands of people who represent the most extreme end of our economic realities. They, beyond the enigmatic smile and face of President Bio and the razzmatazz of the fight against corruption, are the most extreme and visible symptoms of our realities and the sharpest point at the top of the iceberg,</p>
<p style="text-align: justify;">Whether you want to believe it or not, the key element in the economy is the individual consumer. That is the irreducible minimum that we need to focus on. Until the individual&#8217;s disposable income increases, thereby expanding his effective demand, we will be dancing on a roulette wheel.</p>
<p style="text-align: justify;">The very basic preoccupation of government is security, job creation and overarching this is to ensure modicum of equity. In between all these, is the necessity to fashion appropriate dynamic mechanism of maximizing the socio-economic benefits accrued to a large number.</p>
<p style="text-align: justify;">At the moment, our economy is neither fish nor fowl. Whether, it is as a result of the gross incompetence of the agenda for prosperity; or that of the new direction, pales into insignificance. It is merely a luminous symbol of our realities.</p>
<p style="text-align: justify;">Addressing corruption for example, without understanding the political economy of corruption is very dangerous and is akin to sub-optimal theorisation of the practical down-to-earth role of this debilitating scourge in keeping the scope, structure and success of the economy in the near term.</p>
<p style="text-align: justify;">Let’s be frank, if you eliminate corruption, many will starve and die irrespective of which political garb they adorn. To avoid this, is to, amidst other things, find a social safety net for those who depend on corruption on the secondary and tertiary level for survival and implement that simultaneously with the crackdown on corruption.</p>
<p style="text-align: justify;">One of our major mistakes I believe is that we continue to focus on the economy, especially as it relates to the ordinary man, as an abstract entity. By such thinking, all economic policies devolve to the sustenance of government and its structures. It is a cartoon view of our existence that ignores the fact that many struggling under-privileged, sees that fact and the hype around it as something that go on and on like a seamless miasma, while their horrific lives continue to be blighted.</p>
<p style="text-align: justify;">Despite our abundant resources, the perilously scorching bite of poverty has held us back and that is the huge gauntlet that was thrown on the floor of our future by the change of administration last year with the frictionless flow from the APC to the SLPP. Amidst their overwhelming desire for change, the people just want to feel the social and economic benefits of Mother Nature’s windfall to Sierra Leone.</p>
<p style="text-align: justify;">Simply put, the current cost of living, which is now a sing song, is an albatross in a dysfunctional and dystopian society like ours where political gladiators from the ousted APC are doing their best to hold the nation hostage with their antics and are becoming a phenomenon that handicaps cohesive fight against transformation. Added to that is the incomprehensible behaviour of a government that is meant to be more focussed but which does everything to get bogged down with mundane issues that are doing it no favours but simply indicates that politicians will always be politicians.</p>
<p style="text-align: justify;">Nevertheless, as the economy bites harder, should the new direction, after one year, still be dipping its toes in the water or continue to lean on the familiar crutch of the failure or otherwise of its predecessor? True; the government is defying the experts and critics. But one thing is largely responsible. That thing is the change in government from those who were reckless and profligate in abundance to a government who despite the lack, is managing and utilising lean resources efficiently.</p>
<p style="text-align: justify;">So, the tower is still perilously standing on a solid foundation. Serious efforts are in place to avoid tremors but unless the new direction appreciates the fact that without an urgent attention to the economy which is affecting all aspects of business, gradually the murmurs will start. It is not a criticism. It is an observation. The dots need connecting. The truth is that one part needs to connect to the other to work&#8230; </p>
<p style="text-align: justify;">Yes, the APC government made a mess of the economy by its primitive plundering and despoliation of the treasury but the current administration cannot continue to whine and blame the inertia of the economy on that and still expect not to dash the hopes of the people who are gradually streaming towards disillusionment and currently experiencing one of the toughest times in history with the cost of living reaching an all time high.   </p>
<p style="text-align: justify;">If in doubt, take a trip to the nearest market. Prices of goods and services, including, pathetically, so-called home-grown goods, have nosed up and typical of our economics; have refused to respond to the latter day knee-jerk measures of the government.                                                                                               </p>
<p style="text-align: justify;">Apart from the high level of greed, one of the reasons for the exit of the Koroma administration was the economic situation. Therefore if nothing has changed, then let’s start calling a spade a spade. The only thing worse than collective amnesia, is wilful selective amnesia &#8211; it is a potent high concentrated brew of sheer hypocrisy, genetic mediocrity and downright amorality. Our worst can&#8217;t bring out our best, obviously one would think.</p>
<p style="text-align: justify;">People are not interested in just tales of who’s corrupt.  It’s clear to every citizen that the level of corruption in the country is disturbing, even now. Beyond that however, majority are hurting and hungry. The extent people go because of poverty is sometimes alarming&#8230; I totally agree that no matter what structures are put on ground by our government, our lack of empathy and loss of moral compass will not make it work&#8230;.</p>
<p style="text-align: justify;">But what’s going to happen in the short, medium and long term that will assuage the pains that the people have to endure in the marathon to a new Sierra Leone? That is the question.</p>
<p style="text-align: justify;">We are still locked into the high value-low volume mindset in approaching the rebuilding of the economy, I sincerely believe. And our attempts at mass empowerment are, to be polite, forming. Allocation is not a solution; we should focus on utilisation and impact target attainment. Money on its own cannot solve our problems and we don&#8217;t begin to have nearly enough of it any way.</p>
<p style="text-align: justify;">I do not know any magic wand which the government can wave to moderate the expected quick desire of a people pauperised by years of neglect and indifference to their plight but whatever way it can muster, it has to, in a fast manner, set the visible and concrete tone that will show the way of translation from poverty, while expecting the people to be patient.</p>
<p style="text-align: justify;">The people are trusting, even at the risk of becoming highly gullible and despite the wide spread apprehension, disillusion and anger; they are still desperate to follow any Star to National discovery and recovery. But if the government which inherited a deficit economy want us to be patient with it, the people will listen so long as they and their family members live modestly and embark on projects, which identify with the plight of the poor aside the most populist ones.</p>
<p style="text-align: justify;">Yes, transparent projects not suspicious of any financial inducements to them and their cronies as well as which will benefit the poor masses on the long term is the sine qua non. This much is clear.</p>
<p style="text-align: justify;">It is essential that it quickly puts in place, some programmes which are of short term benefits as a relief and reprieve. The new direction cannot embark on selective generosity to any segment of the populace who it thinks it must please in order to remain popular or acceptable; or to people who it thinks can blackmail them or make life difficult for them.</p>
<p style="text-align: justify;">We are in this for a while. Remember when I said it&#8217;s going to be a long dance? Once you get to the bottom of a pit, you need double energy and a good vision to climb out.</p>
<p style="text-align: justify;">We can sing praises and write all the epistles we want to write till thy kingdom come, the mind of a hungry man is a deposit for anger and indifferent attitudes to reading and political carrots. A hungry man has zero thirsts for credible information dissemination. This is the prevailing situation in our society today. We are fast losing our value systems.  While it must be reordered, the once glorious Athens of West Africa stained by the needless blood of many is now bowed as a result of the pains of uncertainty.</p>
<p style="text-align: justify;">Meanwhile, another year and another national birthday celebration went with tempers flaying because the government failed to indulge the people in the old mindset of jollification. But what is there to rejoice about when a once glorious nation has been reduced to one with a begging bowl and is ravaged by the festering wounds of political intolerance, tribalism, corruption, nepotism and the after-effect of the rape of its natural and human resources.</p>
<p style="text-align: justify;">When under what is supposed to be a new direction, they are preaching justice after roofing their reign with shining sheets of inequality and have invented ingenious political and social arguments with a snide at history, as the new anthem for justice, fairness and national cohesion where only those very close to the SLPP kitchen, gets a full meal.</p>
<p style="text-align: justify;">I am a terminal optimist; ‘a believer’ in Sierra Leone’s future greatness. We are yet to live the dreams of our founding fathers. Though we are close to the bottom, but believe me, Salone shall rise again. However, nothing will be salvaged until we stop state and party-sponsored divisiveness and just see each other as citizens with different contributions to make. Just saying.</p>
<p style="text-align: justify;">Tomorrow is not too far. The one who slaps his mistress immediately after a sizzling bedroom act would soon have another erection. </p>
<div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_16 addtoany_list" data-a2a-url="http://www.critiqueecho.com/random-musing-our-worst-cant-bring-out-our-best/" data-a2a-title="Random Musing: Our worst can’t bring out our best."><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=http%3A%2F%2Fwww.critiqueecho.com%2Frandom-musing-our-worst-cant-bring-out-our-best%2F&amp;linkname=Random%20Musing%3A%20Our%20worst%20can%E2%80%99t%20bring%20out%20our%20best." title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"><img src="https://static.addtoany.com/buttons/share_save_120_16.png" alt="Share"></a></div></div><!-- WhatsApp Share Button for WordPress: http://peadig.com/wordpress-plugins/whatsapp-share-button/ --><div class="wabtn_container"><a href="whatsapp://send?text=Random Musing: Our worst can&#8217;t bring out our best. - http://www.critiqueecho.com/random-musing-our-worst-cant-bring-out-our-best/" class="wabtn">Share this on WhatsApp</a></div>
<div class="wpsso-ssb wpsso-ssb-content">
<div class="ssb-buttons en_US">
<!-- Email Button --><div class="css-button email-button">
  <a href="mailto:?subject=Share:%20Random%20Musing%3A%20Our%20worst%20can%E2%80%99t%20bring%20out%20our%20best.&body=Random%20Musing%3A%20Our%20worst%20can%E2%80%99t%20bring%20out%20our%20best.%20%E2%80%93%20There%20is%20a%20usual%20angst%20when%20it%20comes%20to%20writing%20about%20public%20figures%2C%20especially%20when%20these%20figures%20are%20politicians%20who%20are%20caught%20in%20the%20eye%20of%20the%20storm.%20But%20it%20is%20funny%20that%20the%20dogs%20are%20out%20so%20soon%20to%20give%20life%20to%20the%20eerie%20omens%20of%20the%20immediate%20past.%20As%20people%20continue%20to%20gawp%20at%20what%20is%20considered%20by%20some%20to%20be%20the%20logic-defying%20dynamism%20of%20the%20current%20administration%20and%20its%20comprehensible%20vision%2C%20I%20warned%20in%20my%20last%20piece%20that...%0D%0A%0D%0AShared%20from%20http://www.critiqueecho.com/random-musing-our-worst-cant-bring-out-our-best/%0D%0A">
    <span class="ssb-icon">
      <svg xmlns="http://www.w3.org/2000/svg" width="9" height="9" viewBox="0 0 28 28">
        <path d="M20.11 26.147c-2.335 1.05-4.36 1.4-7.124 1.4C6.524 27.548.84 22.916.84 15.284.84 7.343 6.602.45 15.4.45c6.854 0 11.8 4.7 11.8 11.252 0 5.684-3.193 9.265-7.398 9.3-1.83 0-3.153-.934-3.347-2.997h-.077c-1.208 1.986-2.96 2.997-5.023 2.997-2.532 0-4.36-1.868-4.36-5.062 0-4.75 3.503-9.07 9.11-9.07 1.713 0 3.7.4 4.6.972l-1.17 7.203c-.387 2.298-.115 3.3 1 3.4 1.674 0 3.774-2.102 3.774-6.58 0-5.06-3.27-8.994-9.304-8.994C9.05 2.87 3.83 7.545 3.83 14.97c0 6.5 4.2 10.2 10 10.202 1.987 0 4.09-.43 5.647-1.245l.634 2.22zM16.647 10.1c-.31-.078-.7-.155-1.207-.155-2.572 0-4.596 2.53-4.596 5.53 0 1.5.7 2.4 1.9 2.4 1.44 0 2.96-1.83 3.31-4.088l.592-3.72z" />
      </svg>
    </span>
    <span class="ssb-text"></span>
  </a>
</div>
<!-- Facebook Like / Send Button (HTML5) --><div class="fb-like facebook-button" id="facebook-ssb-content-post-9692" data-href="http://www.critiqueecho.com/random-musing-our-worst-cant-bring-out-our-best/" data-send="true" data-layout="button_count" data-show-faces="false" data-font="arial" data-colorscheme="light" data-action="like"></div></div><!-- .ssb-buttons.en_US -->
</div><!-- .wpsso-ssb .wpsso-ssb-content --><!-- generated on 2019-05-07T11:21:30+00:00 -->

<div class="mh-social-bottom">
<div class="mh-share-buttons clearfix">
	<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=http://www.critiqueecho.com/random-musing-our-worst-cant-bring-out-our-best/&t=Random Musing: Our worst can&#8217;t bring out our best.', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
		<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
	</a>
	<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=Random Musing: Our worst can&#8217;t bring out our best. -&url=http://www.critiqueecho.com/random-musing-our-worst-cant-bring-out-our-best/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
		<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
	</a>
	<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=http://www.critiqueecho.com/random-musing-our-worst-cant-bring-out-our-best/&media=http://www.critiqueecho.com/wp-content/uploads/2015/09/bibleimage.jpg&description=Random Musing: Our worst can&#8217;t bring out our best.', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
		<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
	</a>
	<a class="mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=http://www.critiqueecho.com/random-musing-our-worst-cant-bring-out-our-best/', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank">
		<span class="mh-share-button"><i class="fa fa-google-plus"></i></span>
	</a>
	<a class="mh-email" href="mailto:?subject=Random Musing: Our worst can&#8217;t bring out our best.&amp;body=http://www.critiqueecho.com/random-musing-our-worst-cant-bring-out-our-best/" title="Send this article to a friend" target="_blank">
		<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
	</a>
</div></div>
	</div></article><div class="mh-author-box clearfix">
	<figure class="mh-author-box-avatar">
		<img src="http://2.gravatar.com/avatar/2844723e222d9b9d78554d8a40f3b0b2?s=125&#038;r=g" width="125" height="125" alt="" class="avatar avatar-125 wp-user-avatar wp-user-avatar-125 photo avatar-default" />	</figure>
	<div class="mh-author-box-header">
		<span class="mh-author-box-name">
			About CEN		</span>
					<span class="mh-author-box-postcount">
				<a href="http://www.critiqueecho.com/author/cen/" title="More articles written by CEN'">
					673 Articles				</a>
			</span>
			</div>
			<div class="mh-author-box-bio">
			Critique Echo Newspaper is a major source of news and objective analyses about governance, democracy and human-right. Edited and published in Kenema city, eastern Sierra Leone, the outlet is generally referred to as a level plying ground for  the youths, women and children.		</div>
	</div>		<h4 id="mh-comments" class="mh-widget-title mh-comment-form-title">
			<span class="mh-widget-title-inner">
				Be the first to comment			</span>
		</h4>	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/random-musing-our-worst-cant-bring-out-our-best/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="http://www.critiqueecho.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<p class="comment-notes">Your email address will not be published.</p><p class="comment-form-comment"><label for="comment">Comment</label><br/><textarea id="comment" name="comment" cols="45" rows="5" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name </label><span class="required">*</span><br/><input id="author" name="author" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-email"><label for="email">Email </label><span class="required">*</span><br/><input id="email" name="email" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-url"><label for="url">Website</label><br/><input id="url" name="url" type="text" value="" size="30" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='9692' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="a78cb6f0d4" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="174"/></p>			</form>
			</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>		</div>
			<aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"><div id="mh_magazine_posts_list-3" class="mh-widget mh_magazine_posts_list"><div class="mh-posts-list-widget mh-posts-list-hide-caption">
<article class="mh-posts-list-item clearfix post-9692 post type-post status-publish format-standard has-post-thumbnail category-critique-column category-cenheadlines">
	<figure class="mh-posts-list-thumb">
		<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="http://www.critiqueecho.com/random-musing-our-worst-cant-bring-out-our-best/"><img width="326" height="245" src="http://www.critiqueecho.com/wp-content/uploads/2015/09/bibleimage-326x245.jpg" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image" alt="" srcset="http://www.critiqueecho.com/wp-content/uploads/2015/09/bibleimage-326x245.jpg 326w, http://www.critiqueecho.com/wp-content/uploads/2015/09/bibleimage-678x509.jpg 678w, http://www.critiqueecho.com/wp-content/uploads/2015/09/bibleimage-80x60.jpg 80w" sizes="(max-width: 326px) 100vw, 326px" data-wp-pid="7536" nopin="nopin" />		</a>
					<div class="mh-image-caption mh-posts-list-caption">
				Critique Column			</div>
			</figure>
	<div class="mh-posts-list-content clearfix">
		<header class="mh-posts-list-header">
			<h3 class="entry-title mh-posts-list-title">
				<a href="http://www.critiqueecho.com/random-musing-our-worst-cant-bring-out-our-best/" title="Random Musing: Our worst can&#8217;t bring out our best." rel="bookmark">
					Random Musing: Our worst can&#8217;t bring out our best.				</a>
			</h3>
			<div class="mh-meta mh-posts-list-meta">
							</div>
		</header>
		<div class="mh-posts-list-excerpt clearfix">
			<div class="mh-excerpt"><p>There is a usual angst when it comes to writing about public figures, especially when these figures are politicians who are caught in the eye of the storm. But it <a class="mh-excerpt-more" href="http://www.critiqueecho.com/random-musing-our-worst-cant-bring-out-our-best/" title="Random Musing: Our worst can&#8217;t bring out our best.">[Read more]</a></p>
<div class="wpsso-ssb wpsso-ssb-excerpt">
<div class="ssb-buttons en_US">
<!-- Facebook Like / Send Button (HTML5) --></p>
<div class="fb-like facebook-button" id="facebook-ssb-excerpt-post-9692" data-href="http://www.critiqueecho.com/random-musing-our-worst-cant-bring-out-our-best/" data-send="true" data-layout="button_count" data-show-faces="false" data-font="arial" data-colorscheme="light" data-action="like"></div>
</div>
<p><!-- .ssb-buttons.en_US -->
</div>
<p><!-- .wpsso-ssb .wpsso-ssb-excerpt --><!-- generated on 2019-05-07T11:21:30+00:00 --></p>
</div><div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_16 addtoany_list" data-a2a-url="http://www.critiqueecho.com/random-musing-our-worst-cant-bring-out-our-best/" data-a2a-title="Random Musing: Our worst can’t bring out our best."><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=http%3A%2F%2Fwww.critiqueecho.com%2Frandom-musing-our-worst-cant-bring-out-our-best%2F&amp;linkname=Random%20Musing%3A%20Our%20worst%20can%E2%80%99t%20bring%20out%20our%20best." title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"><img src="https://static.addtoany.com/buttons/share_save_120_16.png" alt="Share"></a></div></div>		</div>
	</div>
</article><article class="mh-posts-list-item clearfix post-9689 post type-post status-publish format-standard has-post-thumbnail category-cenheadlines category-randommusing">
	<figure class="mh-posts-list-thumb">
		<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="http://www.critiqueecho.com/random-musing-let-he-that-thinks-he-stands-take-heed/"><img width="326" height="245" src="http://www.critiqueecho.com/wp-content/uploads/2017/10/poitics-326x245.jpg" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image" alt="" srcset="http://www.critiqueecho.com/wp-content/uploads/2017/10/poitics-326x245.jpg 326w, http://www.critiqueecho.com/wp-content/uploads/2017/10/poitics-678x509.jpg 678w, http://www.critiqueecho.com/wp-content/uploads/2017/10/poitics-80x60.jpg 80w" sizes="(max-width: 326px) 100vw, 326px" data-wp-pid="8732" nopin="nopin" />		</a>
					<div class="mh-image-caption mh-posts-list-caption">
				Latest Post			</div>
			</figure>
	<div class="mh-posts-list-content clearfix">
		<header class="mh-posts-list-header">
			<h3 class="entry-title mh-posts-list-title">
				<a href="http://www.critiqueecho.com/random-musing-let-he-that-thinks-he-stands-take-heed/" title="Random Musing: Let He That Thinks He stands Take Heed." rel="bookmark">
					Random Musing: Let He That Thinks He stands Take Heed.				</a>
			</h3>
			<div class="mh-meta mh-posts-list-meta">
							</div>
		</header>
		<div class="mh-posts-list-excerpt clearfix">
			<div class="mh-excerpt"><p>President Bio’s legendry determination to mount the seat of Sierra Leone’s leadership is well known and the performance of his administration and his utterances since assuming power, answer a question <a class="mh-excerpt-more" href="http://www.critiqueecho.com/random-musing-let-he-that-thinks-he-stands-take-heed/" title="Random Musing: Let He That Thinks He stands Take Heed.">[Read more]</a></p>
<div class="wpsso-ssb wpsso-ssb-excerpt">
<div class="ssb-buttons en_US">
<!-- Facebook Like / Send Button (HTML5) --></p>
<div class="fb-like facebook-button" id="facebook-ssb-excerpt-post-9689" data-href="http://www.critiqueecho.com/random-musing-let-he-that-thinks-he-stands-take-heed/" data-send="true" data-layout="button_count" data-show-faces="false" data-font="arial" data-colorscheme="light" data-action="like"></div>
</div>
<p><!-- .ssb-buttons.en_US -->
</div>
<p><!-- .wpsso-ssb .wpsso-ssb-excerpt --><!-- generated on 2019-05-06T13:50:01+00:00 --></p>
</div><div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_16 addtoany_list" data-a2a-url="http://www.critiqueecho.com/random-musing-let-he-that-thinks-he-stands-take-heed/" data-a2a-title="Random Musing: Let He That Thinks He stands Take Heed."><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=http%3A%2F%2Fwww.critiqueecho.com%2Frandom-musing-let-he-that-thinks-he-stands-take-heed%2F&amp;linkname=Random%20Musing%3A%20Let%20He%20That%20Thinks%20He%20stands%20Take%20Heed." title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"><img src="https://static.addtoany.com/buttons/share_save_120_16.png" alt="Share"></a></div></div>		</div>
	</div>
</article><article class="mh-posts-list-item clearfix post-9685 post type-post status-publish format-standard has-post-thumbnail category-critique-column category-cenheadlines">
	<figure class="mh-posts-list-thumb">
		<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="http://www.critiqueecho.com/from-ideas-to-deeds-challenges-of-our-time/"><img width="312" height="240" src="http://www.critiqueecho.com/wp-content/uploads/2019/04/tejansiee.jpg" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image" alt="" srcset="http://www.critiqueecho.com/wp-content/uploads/2019/04/tejansiee.jpg 312w, http://www.critiqueecho.com/wp-content/uploads/2019/04/tejansiee-300x231.jpg 300w, http://www.critiqueecho.com/wp-content/uploads/2019/04/tejansiee-200x154.jpg 200w" sizes="(max-width: 312px) 100vw, 312px" data-wp-pid="9687" nopin="nopin" />		</a>
					<div class="mh-image-caption mh-posts-list-caption">
				Critique Column			</div>
			</figure>
	<div class="mh-posts-list-content clearfix">
		<header class="mh-posts-list-header">
			<h3 class="entry-title mh-posts-list-title">
				<a href="http://www.critiqueecho.com/from-ideas-to-deeds-challenges-of-our-time/" title="FROM IDEAS TO DEEDS: Challenges of Our Time" rel="bookmark">
					FROM IDEAS TO DEEDS: Challenges of Our Time				</a>
			</h3>
			<div class="mh-meta mh-posts-list-meta">
							</div>
		</header>
		<div class="mh-posts-list-excerpt clearfix">
			<div class="mh-excerpt"><p>The most touted first year review of the current SLPP Government has indeed provoked an intense debate that is good and nourishing to our emergent democracy, which discourse had led <a class="mh-excerpt-more" href="http://www.critiqueecho.com/from-ideas-to-deeds-challenges-of-our-time/" title="FROM IDEAS TO DEEDS: Challenges of Our Time">[Read more]</a></p>
<div class="wpsso-ssb wpsso-ssb-excerpt">
<div class="ssb-buttons en_US">
<!-- Facebook Like / Send Button (HTML5) --></p>
<div class="fb-like facebook-button" id="facebook-ssb-excerpt-post-9685" data-href="http://www.critiqueecho.com/from-ideas-to-deeds-challenges-of-our-time/" data-send="true" data-layout="button_count" data-show-faces="false" data-font="arial" data-colorscheme="light" data-action="like"></div>
</div>
<p><!-- .ssb-buttons.en_US -->
</div>
<p><!-- .wpsso-ssb .wpsso-ssb-excerpt --><!-- generated on 2019-05-07T08:28:36+00:00 --></p>
</div><div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_16 addtoany_list" data-a2a-url="http://www.critiqueecho.com/from-ideas-to-deeds-challenges-of-our-time/" data-a2a-title="FROM IDEAS TO DEEDS: Challenges of Our Time"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=http%3A%2F%2Fwww.critiqueecho.com%2Ffrom-ideas-to-deeds-challenges-of-our-time%2F&amp;linkname=FROM%20IDEAS%20TO%20DEEDS%3A%20Challenges%20of%20Our%20Time" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"><img src="https://static.addtoany.com/buttons/share_save_120_16.png" alt="Share"></a></div></div>		</div>
	</div>
</article><article class="mh-posts-list-item clearfix post-9678 post type-post status-publish format-standard has-post-thumbnail category-national-news category-cenheadlines">
	<figure class="mh-posts-list-thumb">
		<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="http://www.critiqueecho.com/sierra-leone-minister-of-labor-social-security-ilo-100th-anniversary-statement/"><img width="326" height="245" src="http://www.critiqueecho.com/wp-content/uploads/2019/04/Mr.-Adekunle-King-326x245.jpg" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image" alt="" srcset="http://www.critiqueecho.com/wp-content/uploads/2019/04/Mr.-Adekunle-King-326x245.jpg 326w, http://www.critiqueecho.com/wp-content/uploads/2019/04/Mr.-Adekunle-King-80x60.jpg 80w" sizes="(max-width: 326px) 100vw, 326px" data-wp-pid="9682" nopin="nopin" />		</a>
					<div class="mh-image-caption mh-posts-list-caption">
				Breaking News			</div>
			</figure>
	<div class="mh-posts-list-content clearfix">
		<header class="mh-posts-list-header">
			<h3 class="entry-title mh-posts-list-title">
				<a href="http://www.critiqueecho.com/sierra-leone-minister-of-labor-social-security-ilo-100th-anniversary-statement/" title="Sierra Leone Minister of Labor &#038; Social Security ILO 100th Anniversary Statement" rel="bookmark">
					Sierra Leone Minister of Labor &#038; Social Security ILO 100th Anniversary Statement				</a>
			</h3>
			<div class="mh-meta mh-posts-list-meta">
							</div>
		</header>
		<div class="mh-posts-list-excerpt clearfix">
			<div class="mh-excerpt"><p>The International Labor Organization (ILO) founded in 1919 brings together governments, employers and workers with a mission to defend workers rights, encourage decent job opportunities and advocate for social justice. <a class="mh-excerpt-more" href="http://www.critiqueecho.com/sierra-leone-minister-of-labor-social-security-ilo-100th-anniversary-statement/" title="Sierra Leone Minister of Labor &#038; Social Security ILO 100th Anniversary Statement">[Read more]</a></p>
<div class="wpsso-ssb wpsso-ssb-excerpt">
<div class="ssb-buttons en_US">
<!-- Facebook Like / Send Button (HTML5) --></p>
<div class="fb-like facebook-button" id="facebook-ssb-excerpt-post-9678" data-href="http://www.critiqueecho.com/sierra-leone-minister-of-labor-social-security-ilo-100th-anniversary-statement/" data-send="true" data-layout="button_count" data-show-faces="false" data-font="arial" data-colorscheme="light" data-action="like"></div>
</div>
<p><!-- .ssb-buttons.en_US -->
</div>
<p><!-- .wpsso-ssb .wpsso-ssb-excerpt --><!-- generated on 2019-05-08T05:42:33+00:00 --></p>
</div><div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_16 addtoany_list" data-a2a-url="http://www.critiqueecho.com/sierra-leone-minister-of-labor-social-security-ilo-100th-anniversary-statement/" data-a2a-title="Sierra Leone Minister of Labor &amp; Social Security ILO 100th Anniversary Statement"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=http%3A%2F%2Fwww.critiqueecho.com%2Fsierra-leone-minister-of-labor-social-security-ilo-100th-anniversary-statement%2F&amp;linkname=Sierra%20Leone%20Minister%20of%20Labor%20%26%20Social%20Security%20ILO%20100th%20Anniversary%20Statement" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"><img src="https://static.addtoany.com/buttons/share_save_120_16.png" alt="Share"></a></div></div>		</div>
	</div>
</article></div>
</div>	</aside>	</div>
    </div>
<a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a>
</div><!-- .mh-container-outer -->
<footer class="mh-footer" itemscope="itemscope" itemtype="http://schema.org/WPFooter">
<div class="mh-container mh-container-inner mh-footer-widgets mh-row clearfix">
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-1">
<div id="mh_magazine_youtube-6" class="mh-footer-widget mh_magazine_youtube"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><i class="fa fa-youtube-play"></i>Independence</span></h6>			<div class="mh-video-widget">
        		<div class="mh-video-container">
        			<iframe seamless width="1280" height="720" src="//www.youtube.com/embed/ztUXY_IYT0U?wmode=opaque&amp;hd=1&amp;autoplay=0&amp;showinfo=0&amp;controls=2&amp;rel=1" allowfullscreen></iframe>
        		</div>
			</div></div><div id="mh_magazine_youtube-11" class="mh-footer-widget mh_magazine_youtube"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><i class="fa fa-youtube-play"></i>Rising from the ashes</span></h6>			<div class="mh-video-widget">
        		<div class="mh-video-container">
        			<iframe seamless width="1280" height="720" src="//www.youtube.com/embed/RZqNomg33Yw?wmode=opaque&amp;hd=1&amp;autoplay=0&amp;showinfo=0&amp;controls=2&amp;rel=1" allowfullscreen></iframe>
        		</div>
			</div></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-2">
<div id="mh_magazine_youtube-3" class="mh-footer-widget mh_magazine_youtube"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><i class="fa fa-youtube-play"></i><a href="https://www.youtube.com/results?search_query=lansana+sheriff" class="mh-widget-title-link">Lansana Sheriff</a></span></h6>			<div class="mh-video-widget">
        		<div class="mh-video-container">
        			<iframe seamless width="1280" height="720" src="//www.youtube.com/embed/Bj8B2AkZUNs?wmode=opaque&amp;hd=1&amp;autoplay=0&amp;showinfo=0&amp;controls=2&amp;rel=1" allowfullscreen></iframe>
        		</div>
			</div></div><div id="mh_magazine_youtube-4" class="mh-footer-widget mh_magazine_youtube"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><i class="fa fa-youtube-play"></i>Gbetuwai</span></h6>			<div class="mh-video-widget">
        		<div class="mh-video-container">
        			<iframe seamless width="1280" height="720" src="//www.youtube.com/embed/QMoXMK4--uQ?wmode=opaque&amp;hd=1&amp;autoplay=0&amp;showinfo=0&amp;controls=2&amp;rel=1" allowfullscreen></iframe>
        		</div>
			</div></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-3">
<div id="mh_magazine_youtube-5" class="mh-footer-widget mh_magazine_youtube"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><i class="fa fa-youtube-play"></i>Salia Koroma</span></h6>			<div class="mh-video-widget">
        		<div class="mh-video-container">
        			<iframe seamless width="1280" height="720" src="//www.youtube.com/embed/AxrZy1LKzto?wmode=opaque&amp;hd=1&amp;autoplay=0&amp;showinfo=0&amp;controls=2&amp;rel=1" allowfullscreen></iframe>
        		</div>
			</div></div><div id="mh_magazine_youtube-8" class="mh-footer-widget mh_magazine_youtube"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><i class="fa fa-youtube-play"></i>Jebbeh 2</span></h6>			<div class="mh-video-widget">
        		<div class="mh-video-container">
        			<iframe seamless width="1280" height="720" src="//www.youtube.com/embed/1EoYXBOpMOY?wmode=opaque&amp;hd=1&amp;autoplay=0&amp;showinfo=0&amp;controls=2&amp;rel=1" allowfullscreen></iframe>
        		</div>
			</div></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-4">
<div id="mh_magazine_youtube-10" class="mh-footer-widget mh_magazine_youtube"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><i class="fa fa-youtube-play"></i>Muku Boss Pan Matches</span></h6>			<div class="mh-video-widget">
        		<div class="mh-video-container">
        			<iframe seamless width="1280" height="720" src="//www.youtube.com/embed/1pFTqLWXtlM?wmode=opaque&amp;hd=1&amp;autoplay=0&amp;showinfo=0&amp;controls=2&amp;rel=1" allowfullscreen></iframe>
        		</div>
			</div></div><div id="mh_magazine_youtube-9" class="mh-footer-widget mh_magazine_youtube"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><i class="fa fa-youtube-play"></i>Yesterday Bette Pass Tiday</span></h6>			<div class="mh-video-widget">
        		<div class="mh-video-container">
        			<iframe seamless width="1280" height="720" src="//www.youtube.com/embed/rxJdUlh_mlU?wmode=opaque&amp;hd=1&amp;autoplay=0&amp;showinfo=0&amp;controls=2&amp;rel=1" allowfullscreen></iframe>
        		</div>
			</div></div><div id="search-5" class="mh-footer-widget widget_search"><form role="search" method="get" class="search-form" action="http://www.critiqueecho.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></div></div>
</div>
</footer>
	<div class="mh-footer-nav-mobile"></div>
	<nav class="mh-navigation mh-footer-nav" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
		<div class="mh-container mh-container-inner clearfix">
			<div class="menu-cen-container"><ul id="menu-cen-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-8385"><a href="http://www.critiqueecho.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-6948"><a href="http://www.critiqueecho.com/category/critique-column/">Critique</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6952"><a href="http://www.critiqueecho.com/category/diasporal-exclusive/">Diasporal Exclusive</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6954"><a href="http://www.critiqueecho.com/category/world-news/">World News</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6955"><a href="http://www.critiqueecho.com/category/world-news/african-news/">Africa</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6956"><a href="http://www.critiqueecho.com/category/world-news/middle-east/">Middle East/Asia</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7253"><a href="http://www.critiqueecho.com/category/world-news/african-news/">Africa</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7254"><a href="http://www.critiqueecho.com/category/world-news/american-news/">America</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7255"><a href="http://www.critiqueecho.com/category/world-news/european-news/">Europe</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7181"><a href="http://www.critiqueecho.com/category/randommusing/">Random Musing</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7182"><a href="http://www.critiqueecho.com/category/poems/">Poems</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-8481"><a href="#">Useful links</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8485"><a href="http://www.sierra-leone.org/">Sierra Leone Web</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8483"><a href="#">Tourist info</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8484"><a href="#">Local news</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6953"><a href="http://www.critiqueecho.com/category/sport/">Sport</a></li>
</ul></div>		</div>
	</nav>
<div class="mh-copyright-wrap">
	<div class="mh-container mh-container-inner clearfix">
		<p class="mh-copyright">
			Critique Echo Newspaper 2010 © - all rights reserved. The outlet is the main source of news and objective analysis about peace, governance, human rights, democracy and socioeconomic development in post conflict Sierra Leone. It’s edited and published in Kenema city, eastern province, by Othman Sheriff		</p>
	</div>
</div>
<link rel='stylesheet' id='google-news-style-css'  href='http://www.critiqueecho.com/wp-content/plugins/simple-google-news/css/style.css?ver=20120208' type='text/css' media='all' />
<script type='text/javascript' src='http://www.critiqueecho.com/wp-includes/js/comment-reply.min.js?ver=5.0.4'></script>
<script type='text/javascript' src='http://www.critiqueecho.com/wp-includes/js/wp-embed.min.js?ver=5.0.4'></script>
<script async="async" type='text/javascript' src='http://www.critiqueecho.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.1'></script>
<div id="wpsso-ssb-sidebar-container"><div id="wpsso-ssb-sidebar-header"></div>
<div class="wpsso-ssb" id="wpsso-ssb-sidebar">
<div class="wpsso-ssb-preset-large_share_vertical">
<div class="ssb-buttons en_US">
<!-- Facebook Share Button (HTML5) --><div class="fb-share fb-share-button" id="fb-share-ssb-sidebar-post-9692" data-href="http://www.critiqueecho.com/random-musing-our-worst-cant-bring-out-our-best/" data-layout="box_count" data-mobile_iframe="true" data-size="small"></div></div><!-- .ssb-buttons.en_US -->
</div><!-- .wpsso-ssb-preset-large_share_vertical -->
</div><!-- .wpsso-ssb #wpsso-ssb-sidebar --><!-- generated on 2019-05-07T11:22:06+00:00 -->

</div>
<script type="text/javascript">jQuery("#wpsso-ssb-sidebar-container").mouseenter( function(){ 
	jQuery("#wpsso-ssb-sidebar").css({
		"display":"block",
		"width":"auto",
		"height":"auto",
		"overflow":"visible",
		"border-style":"none",
	}); } );
jQuery("#wpsso-ssb-sidebar-header").click( function(){ 
	jQuery("#wpsso-ssb-sidebar").toggle(); } );</script>
<!-- wpssossb footer javascript begin -->
<!-- generated on 2019-05-09T06:54:59+00:00 -->
<script type="text/javascript" id="fb-script-footer">wpsso_insert_js( "fb-script-footer", "http://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6&appId=234540849953303" );</script>
<!-- wpssossb footer javascript end -->
</body>
</html>